Sunday, February 13, 2011

PSU and Upgrades

While upgrading  one of the instances on a server . We hit an error
ORA-00600: internal error code, arguments: [kccgtt_1], [3], [], [], [], [], [],
The Error was interesting and points to an aspect of the prechecks that we hadnt explored before. Differences in PSU Levels between Homes. The Database Home was installed recently and since it was a new Home the latest PSU was applied. What wasnt done was checking the ASM Home for the PSU level. Turns out ASM Home has 11.1.0.7.2 vs Database Home having 11.1.0.7.4. ASM has to follow the rule of Same or Higher patch level the the highest level of Database version.
Once ASM was Patched All was well but it just adds another layer of checking that DBA's have to do when installing or Upgrading Oracle.

Google Search